Home
Como Instalar Plugins Python no QGIS
Instalando Plugins Python no Quantum GIS

Como Instalar Plugins Python no QGIS

Instalar Plugins Python no QGIS

Na sua forma nativa o QGIS já possui um bom número de ferramentas úteis para trabalhos de Geoprocessamento. Entretanto, há certas tarefas que apenas poderão ser executadas de forma satisfatória após a instalação de plugins (complementos) escritos na linguagem Python. Veremos neste tutorial como fazer a instalação de uma destas extensões (Table Manager), que serve para gestão da estrutura das tabelas de atributos dos dados geográficos como, por exemplo, criação e exclusão de campos.

TUTORIAL DE INSTALAÇÃO DE COMPLEMENTOS NO QGIS

Entenda que quando falamos em plugins neste contexto estamos nos referindo a um pequeno aplicativo, ferramenta ou rotina que acrescenta funcionalidades ao QGIS.

Veja este tutorial também em formato de vídeo (Inscreva-se em nosso Canal no Youtube):

https://www.youtube.com/watch?v=jVvD8DUC_iM

Um detalhe importante: Certifique-se de estar conectado à internet, pois a mesma será utilizada para fazermos o download dos “pacotes” de cada extensão.

1° Passo: Acesse o Menu Complementos > Gerenciar e Instalar Complementos…

Complementos Python…

2° Passo: Após o programa abrir o instalador de Complementos Python, note a lista de extensões disponíveis para instalação.

Como Instalar Plugins Python no QGIS

3° Passo: Comece a digitar o nome da extensão desejada. Como já citado, neste exemplo queremos instalar o plugin Table Manager.

Table Manager

4° Passo: Selecione a extensão desejada clicando sobre o nome e em seguida clique em Instalar Complemento.

Ocorrendo tudo bem durante o rápido processo de instalação, deverá aparecer uma mensagem informando sobre o sucesso da operação.

Instalar Complemento

5° Passo: Procure o ícone da extensão instalada na barra de ferramentas Complementos.

Instalar Complemento no QGIS

Gostaria de fazer o download da primeira versão deste tutorial (no QGIS 1.7.4) completo no formato PDF? Acesse:

  • [download id=”33″]

MATÉRIAS RELACIONADAS

Caso você tenha alguma dúvida, elogio, crítica ou sugestão, fique à vontade para entrar em c0ntato. Por favor, deixem sua opinião sobre o tutorial nos comentários!

 Assine nosso FeedAssine nosso Feed e receba nossas atualizações por e-mail. Curta nossa página no Facebook [PortalClickGeo] e siga nosso Twitter [@ClickGeo] para continuar atualizado sobre o Mundo das Geotecnologias.]]>

Tags:

55 Comments

  • Sívori disse:

    Muito legal Sr. Anderson.
    Existem coisas no mundo geo que a gente leva tempo prá saber o seu real significado.
    Muitos são os conceitos e eles vêm juntos e a gente não consegue digerir.
    À medida que o tempo passa as coisas vão clareando.
    Finalmente chegou a vez do tal do Python que prá mim parece caviar, a gente sabe que existe mas só ouve falar.
    Valeu e aquele abraço.

  • Andrea Carla disse:

    Para mim esse tutorial foi perfeito, pois era justamente um plugin para essa finalidade que eu estava procurando.
    Obrigada Anderson.

  • Boa tarde Anderson… voce tem algum manual em português desse software (Quantum GIS) ? quero muito conhecê-lo. Onde trabalho o pessoal o utiliza, mas eu sou leigo na área

  • […] Instalando Plugins Python no Quantum GIS – por Anderson Medeiros […]

  • Diogo Carib'e disse:

    Anderson, vc sabe se existe uma ferramenta split no quantunGis ou em outro software livre?

  • Marco Antonio disse:

    Bom dia, Anderson.
    Instalei o QGIS, mas não estou conseguindo instalar o SEXTANTE. Sou leigo tanto em GIS quanto no Linux, instalei hoje na minha máquina os dois (OS e Software) e pretendo estudar um pouco.
    Uso Ubuntu 12.04 (x64). Poderia me ajudar com o script para fazer via terminal. Sugestão, acho que seria interessante colocar um passo-a-passo para leigos (como eu) instalar via terminal.
    Um abraço e parabéns pelo página.

  • Ricardo Cardoso disse:

    boa tarde.
    instalei o qgis, mas precisava de estabelecer ligaçao com o google earth.
    como posso fazer?
    agradecia a ajuda.
    Ricardo Cardoso

  • Eduardo Mota disse:

    Quero instalar o plugin Terra Legal no QGIS Lisboa 1.8 e da um erro medonho nao instala..poderia me ajudar…
    Abraços…
    Aguardo respostas por favor..
    t+

  • Ricardo Rodrigues disse:

    Boas!
    Gostaria de saber se é possivel instalar o Sextante em modo offline.
    Cumprimentos!

  • frederico disse:

    Instala os plugins mas nada funciona. Retorna um erro de execução do python infelizmente tentando resolver a dias.

  • ELVIS RICHARD disse:

    Não consigo delimitar bacias hidro no Qgis usando o Taudem.
    Instalei o Taudem e o MPICH2. Qndo executo o PIT REMOVE fica somente processando. Tem como me ajudar?

  • Rafael Nágem disse:

    No meu caso aparece isso.. o que deve ser ?
    Impossível carregar complemento ‘elevation’ de [‘C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python’, ‘C:/Users/Nágem/.qgis//python’, ‘C:/Users/Nágem/.qgis//python/plugins’, ‘C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python/plugins’, ‘C:\Windows\system32\python27.zip’, ‘C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\DLLs’, ‘C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib’, ‘C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\plat-win’, ‘C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\lib-tk’, ‘C:\PROGRA~2\Quantum GIS Lisboa\apps\qgis\bin’, ‘C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27’, ‘C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages’, ‘C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\PIL’, ‘C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\win32’, ‘C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\win32\lib’, ‘C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\Pythonwin’, ‘C:\PROGRA~2\Quantum GIS Lisboa\apps\Python27\lib\site-packages\wx-2.8-msw-unicode’, ‘C:\PROGRA~2\Quantum GIS Lisboa\apps\qgis\python\plugins\fTools\tools’]
    Traceback (most recent call last):
    File “C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python\qgis\utils.py”, line 143, in loadPlugin
    __import__(packageName)
    File “C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python\qgis\utils.py”, line 309, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
    ImportError: No module named elevation
    Versão do Python:
    2.7.2 (default, Jun 12 2011, 15:08:59) [MSC v.1500 32 bit (Intel)]
    Versão do QGIS
    1.8.0-Lisboa Lisboa, 6416f38
    Caminho para o Python: [‘C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python’, ‘C:/Users/N\xc3\xa1gem/.qgis//python’, ‘C:/Users/N\xc3\xa1gem/.qgis//python/plugins’, ‘C:/PROGRA~2/Quantum GIS Lisboa/apps/qgis/./python/plugins’, ‘C:\\Windows\\system32\\python27.zip’, ‘C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\DLLs’, ‘C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\lib’, ‘C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\lib\\plat-win’, ‘C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\lib\\lib-tk’, ‘C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\qgis\\bin’, ‘C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27’, ‘C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\lib\\site-packages’, ‘C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\lib\\site-packages\\PIL’, ‘C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\lib\\site-packages\\win32’, ‘C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\lib\\site-packages\\win32\\lib’, ‘C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\lib\\site-packages\\Pythonwin’, ‘C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\Python27\\lib\\site-packages\\wx-2.8-msw-unicode’, ‘C:\\PROGRA~2\\Quantum GIS Lisboa\\apps\\qgis\\python\\plugins\\fTools\\tools’]
    Alguém pode me ajudar ??
    Obrigado

  • Rafael Nágem disse:

    Fui instalar o plugin Elevation, e deu esse erro. Assim como vários plugins que tentei instalar.

  • Rafael Nágem disse:

    Esqueci de comentar que na versão 1.8 do QGIS não tem essa opção de “Adicionar um grupo de terceiro repositório”.
    Parabéns pelo site.

  • fred disse:

    No meu caso, deixei de usar o qgis e retornei para o arc gis comprando umw licença
    Home, com todas as ferramentas abertas durante um ano. Como presto muita consultoria e não posso passar mais da metade do meu dia tentando resolver problemas de plugins disso ou daquilo, essa foi a solução, retornar
    ao Arcgis original.

  • Emerson dos Santos Braga disse:

    Olá Anderson, parabéns pelo site. Sou iniciante, tinha o qgis 1.8 e utilizava-o bem dentro de minha capacidade. Baixei a versão 2.0.1 e quando tento entrar nos complementos para usar as imagens do google aparece uma mensagem de erro pythotn. Você poderia me ajudar.
    Desde já agradeço sua atenção
    Émerson

  • Sabrina Silva disse:

    Oi… Preciso de ajuda para instalar o complemento Python no Qgis 2.0. Pois com a atualização do programa muita coisa mudou. Grata.

  • Jorge Miguel Silva Gomes disse:

    Boa Tarde, Anderson, estou começando a trabalhar com o QGIS 2.2.0 e não estou conseguindo introduzir o mapa do google para poder trabalhar e estudar. Será que era possível me dar uma ajuda inicial. Abraço

  • Israel disse:

    Anderson, instalei o complemento conforme o tutorial porém ele não aparece para execução. Tem ideia do que pode estar acontecendo de errado?
    Grato!

  • João Gabriel disse:

    Obrigado pelos tutoriais, eles tem me ajudado muito, porém quando fui instalar o points2one o pynthon afirma que o arquivo está corrompido. Como devo proceder?

  • Danúbia disse:

    Anderson, estou começando a utilizar o QGIS agora e não consigo instalar os complementos. O link do repositório não conecta. Você sabe me dizer por que isso acontece? Eu até salvei o plugin pra copiar pra pasta mas no meu trabalho não tenho permissão para isso.

  • Edson Pinto disse:

    Anderson,
    Não consigo instalar o pluguin do GEarth. Erro ” no module zope.interface”. Meu Windons 7 64 bits. Já descmpatei as pastas do twsite no apps do pitton e nada. Sera que é incompativel 7 64bits?

  • Ricardo disse:

    Algoritmo Pit Remove iniciando…
    Segui o passo a passo e o Taudem está dando o erro abaixo, Você pode me ajudar
    Comando TauDEM:
    C:\Program Files\Microsoft HPC Pack 2012\Bin\mpiexec -n 2 C:\Program Files\TauDEM\TauDEM5Exe\pitremove -z C:\Users\Ricardo Tadeu\Documents\Técnicos\GPS\Curso_qgis\BACIA_RP.tif -fel C:/Users/Ricardo Tadeu/Documents/Técnicos/GPS/Curso_qgis/taudem/BACIA_RP1.tif”
    ‘ascii’ codec can’t encode character u’\xe9′ in position 151: ordinal not in range(128) See log for more details

  • Carol disse:

    Boa tarde, Não consigo instalar o MMQGIS. Eu instalo o plugin e ele não aparece de jeito nenhum. Você sabe o que pode estar acontecendo? Já tentei algumas vezes, reinstalei, desinstalei….
    Obrigada.

  • Eny Regina disse:

    Bom dia Anderson,
    Seus tutoriais são muito bons, e tem me ajudado muito!
    Não entendo nada de programação e é a minha primeira esperiência com georreferenciamento. Estou tentando geocodificar endereços em uma planilha csv UTF-8, usando o complemento MMQGIS. Durante o processo surge a mensagem:
    “Erro Python: Um erro ocorreu enquanto executava o código Python: Consulte o registro de mensagens (Erro Python) para mais detalhes” e no registro de mensagens aparece:
    File “C:/Users/Eny/.qgis2/python/plugins\mmqgis\mmqgis_dialogs.py”, line 1358, in run
    shapefilename, notfoundfile, fields, service, apikey, 1)
    File “C:/Users/Eny/.qgis2/python/plugins\mmqgis\mmqgis_library.py”, line 2423, in mmqgis_geocode_web_service
    x, y, addrtype, addrlocat, formatted_addr = mmqgis_geocode_address_osm(address)
    File “C:/Users/Eny/.qgis2/python/plugins\mmqgis\mmqgis_library.py”, line 388, in mmqgis_geocode_address_osm
    message = “Failure connecting to maps.googleapis.com: ” + unicode(e)
    UnicodeDecodeError: ‘ascii’ codec can’t decode byte 0xe3 in position 36: ordinal not in range(128)
    Você pode me ajudar?
    Desde já agradeço,
    Eny

  • lumimevi disse:

    Boa Noite, gostaria saber como inserir o plugin Swat no Qgis (usu ubuntu 16.4)
    Obrigada

  • Christianne disse:

    Anderson,
    bom dia, quando não aparece nos complementos os pluggins que ue preciso como: table manager e cloud, como fazer?

  • Victória disse:

    Boa Noite Anderson,
    Estou tendo dificuldades para instalar o plugin Space Syntax Toolkit, uma vez que ele nao aparece como opção para ser instalado no gerenciador. Ja fiz o download de todos os arquivos necessarios para que seja feita a intalação e mesmo assim continua nao aparecendo no gerenciador nem na aba de “não instaladods” pode me ajudar? obrigada desde ja!

  • Ronald Stefanello de Azevedo Alves disse:

    Bom dia!
    Ao instalar o plugin de símbolos (Resource sharing) ocorre o seguinte erro:
    Error:
    o que faço para corrigir?
    Obrigado, Ronald.

  • Alexandre disse:

    Olá Anderson. Estou lendo os seus tutoriais, pois estou migrando do ARCGIS para o QGIS. Estou apanhando para inserir simbolos de foliação, acamamento, falhas, dobras, etc…… Estou usando o QGIS 3.2 e no SVEG dele, não tenho esses simbolos. Ja rodei a rede atras desses simbolos. Me de uma dica de onde fazer o download. Um abraçõ!!!

  • Ivanor Zacharias disse:

    Olá, primeiramente parabens pelo site. Estou com um problema, quando tento baixar os complementos aparece um erro: “A instalação do complemento falhou:SSL handshake failed”. Sabe o que esta acontecendo?

Leave a Comment

*

*